summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-10-14 18:22:46 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-10-14 18:22:46 +0200
commitb06cdce923d6b8b40c1238cb1a2b9db277d3394e (patch)
treeb1f595e587020cf9aff6dd390610ecce2ce20531 /gnu
parent40be965e28062ab37ab7c7ed6647600fa8671ed0 (diff)
downloadpatches-b06cdce923d6b8b40c1238cb1a2b9db277d3394e.tar
patches-b06cdce923d6b8b40c1238cb1a2b9db277d3394e.tar.gz
gnu: Add r-velocyto.
* gnu/packages/bioinformatics.scm (r-velocyto): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm44
1 files changed, 44 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index a573ef682f..12c30236cb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -15260,3 +15260,47 @@ and/or unmapped/clipped reads to a separate FASTQ file. When marking
duplicates, samblaster will require approximately 20MB of memory per 1M read
pairs.")
(license license:expat)))
+
+(define-public r-velocyto
+ (let ((commit "d7790346cb99f49ab9c2b23ba70dcf9d2c9fc350")
+ (revision "1"))
+ (package
+ (name "r-velocyto")
+ (version (git-version "0.6" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/velocyto-team/velocyto.R.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "16wqf70j7rd7pay2q513iyz12i8n9vrpg1bisah4lddbcpx5dz1n"))))
+ (build-system r-build-system)
+ (inputs
+ `(("boost" ,boost)))
+ (propagated-inputs
+ `(("r-hdf5r" ,r-hdf5r)
+ ("r-mass" ,r-mass)
+ ("r-mgcv" ,r-mgcv)
+ ("r-pcamethods" ,r-pcamethods)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ;; Suggested packages
+ ("r-rtsne" ,r-rtsne)
+ ("r-cluster" ,r-cluster)
+ ("r-abind" ,r-abind)
+ ("r-h5" ,r-h5)
+ ("r-biocgenerics" ,r-biocgenerics)
+ ("r-genomicalignments" ,r-genomicalignments)
+ ("r-rsamtools" ,r-rsamtools)
+ ("r-edger" ,r-edger)
+ ("r-igraph" ,r-igraph)))
+ (home-page "http://velocyto.org")
+ (synopsis "RNA velocity estimation in R")
+ (description
+ "This package provides basic routines for estimation of gene-specific
+transcriptional derivatives and visualization of the resulting velocity
+patterns.")
+ (license license:gpl3))))