summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorStephen Webber <montokapro@gmail.com>2019-10-13 10:38:52 -0500
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2019-10-14 17:19:54 +0200
commit534610d820a52dcf76b34515c86d704ded590805 (patch)
treebde3f984e7e4209da27ff79b1b6a5c70afca9434 /gnu
parent8c26b18453a6b64fd9f15cf0a700ade3ca4cf72d (diff)
downloadpatches-534610d820a52dcf76b34515c86d704ded590805.tar
patches-534610d820a52dcf76b34515c86d704ded590805.tar.gz
gnu: Add emacs-dimmer.
* gnu/packages/emacs-xyz.scm (emacs-dimmer): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index bbafd548b1..fce49cc40f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -54,6 +54,7 @@
;;; Copyright © 2019 Amin Bandali <bandali@gnu.org>
;;; Copyright © 2019 Jelle Licht <jlicht@fsfe.org>
;;; Copyright © 2019 Björn Höfling <bjoern.hoefling@bjoernhoefling.de>
+;;; Copyright © 2019 Stephen Webber <montokapro@gmail.com>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -19161,3 +19162,26 @@ Emacs that integrate with major modes like Org-mode.")
"Elixir-Mode Provides font-locking, indentation and navigation support
for the Elixir programming language.")
(license license:gpl3+)))
+
+(define-public emacs-dimmer
+ (package
+ (name "emacs-dimmer")
+ (version "0.3.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/gonewest818/dimmer.el.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1jv9rrv15nb5hpwcaqlpjj932gyisrkwbv11czkg3v0bn7qn6yif"))))
+ (build-system emacs-build-system)
+ (home-page "https://github.com/gonewest818/dimmer.el")
+ (synopsis "Visually highlights the selected buffer in Emacs")
+ (description "Dimmer provides a minor mode that indicates which buffer is
+currently active by dimming the faces in the other buffers. It does this
+nondestructively, and computes the dimmed faces dynamically such that your
+overall color scheme is shown in a muted form without requiring you to define
+what is a \"dim\" version of every face.")
+ (license license:gpl3+)))