summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-09-15 22:51:52 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-09-15 22:51:52 +0200
commitf5349b4d5a4a9c93da9eed79e32461df6606cbde (patch)
treef4f07491e2ab1577e9cb0dd075f21fa91bfe9e6a /gnu
parent4c63eeb8a45762b9135d8ed192ce61a4469d1348 (diff)
downloadpatches-f5349b4d5a4a9c93da9eed79e32461df6606cbde.tar
patches-f5349b4d5a4a9c93da9eed79e32461df6606cbde.tar.gz
gnu: Add r-genomegraphs.
* gnu/packages/bioconductor.scm (r-genomegraphs): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioconductor.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/bioconductor.scm b/gnu/packages/bioconductor.scm
index 9cb4ca36e8..807ddedc75 100644
--- a/gnu/packages/bioconductor.scm
+++ b/gnu/packages/bioconductor.scm
@@ -5947,3 +5947,31 @@ provides methods for retrieving enriched pathways.")
model, amino acid change consequence, minor allele frequencies across human
populations, splice site strength, conservation, etc.")
(license license:artistic2.0)))
+
+(define-public r-genomegraphs
+ (package
+ (name "r-genomegraphs")
+ (version "1.44.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (bioconductor-uri "GenomeGraphs" version))
+ (sha256
+ (base32
+ "026skcn2cqchlzaqsnk11gb8d8aq1rz7lrnx4mmsba234mh4j7kd"))))
+ (properties `((upstream-name . "GenomeGraphs")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-biomart" ,r-biomart)))
+ (home-page "https://bioconductor.org/packages/GenomeGraphs/")
+ (synopsis "Plotting genomic information from Ensembl")
+ (description
+ "Genomic data analyses requires integrated visualization of known genomic
+information and new experimental data. GenomeGraphs uses the biomaRt package
+to perform live annotation queries to Ensembl and translates this to e.g.
+gene/transcript structures in viewports of the grid graphics package. This
+results in genomic information plotted together with your data. Another
+strength of GenomeGraphs is to plot different data types such as array CGH,
+gene expression, sequencing and other data, together in one plot using the
+same genome coordinate system.")
+ (license license:artistic2.0)))