summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2019-07-27 17:02:43 -0400
committerMark H Weaver <mhw@netris.org>2019-07-27 17:07:51 -0400
commitd0aff873373ae4ad40d007ac6ebf5500ef40b6d1 (patch)
treecc6cca97af72d71a37de429f5934203ac03756ed /gnu
parent24446ce299943efe3dfded6c9dd0cf9421d8da04 (diff)
downloadpatches-d0aff873373ae4ad40d007ac6ebf5500ef40b6d1.tar
patches-d0aff873373ae4ad40d007ac6ebf5500ef40b6d1.tar.gz
gnu: linux-libre: Verbosely pack the deblobbed linux-libre tarball.
This works around timeouts that sometimes occur after 1 hour of silence while packing the linux-libre source tarball on slower machines. * gnu/packages/linux.scm (make-linux-libre-source): Pass 'v' to 'tar' when packing the result tarball.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm2
1 files changed, 1 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 4689c61a58..6119622d2d 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -312,7 +312,7 @@ corresponding UPSTREAM-SOURCE (an origin), using the given DEBLOB-SCRIPTS."
(format #t "~%Packing new Linux-libre tarball...~%")
(force-output)
- (invoke "tar" "cfa" #$output
+ (invoke "tar" "cvfa" #$output
;; Avoid non-determinism in the archive.
"--mtime=@0"
"--owner=root:0"