summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-07-22 15:50:42 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-07-23 22:01:28 +0200
commit71d20587a5c8e1d8c5025322e27f9312586e9b99 (patch)
tree660fb8c5587f8d574a5e20c342056f125cb34a8a /gnu
parent9e5ee6b60cb7d2a0bc0281634e3e434c885877a6 (diff)
downloadpatches-71d20587a5c8e1d8c5025322e27f9312586e9b99.tar
patches-71d20587a5c8e1d8c5025322e27f9312586e9b99.tar.gz
gnu: python-matplotlib: Update to 2.0.2.
* gnu/packages/python.scm (python-matplotlib): Update to 2.0.2. [source]: Use 'pypi-uri'.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index 6d9963dec4..698fb605fd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4115,16 +4115,14 @@ convert between colorspaces like sRGB, XYZ, CIEL*a*b*, CIECAM02, CAM02-UCS, etc.
(define-public python-matplotlib
(package
(name "python-matplotlib")
- (version "2.0.0")
+ (version "2.0.2")
(source
(origin
(method url-fetch)
- (uri (string-append
- "https://github.com/matplotlib/matplotlib/archive/v" version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (uri (pypi-uri "matplotlib" version))
(sha256
(base32
- "0w3k5m5qb3wsd7yhvmg042xddvligklvcq2visk2c5wnph3hhsln"))))
+ "1w8z2a1l7s72p1byfz7g03wqhygqxi8w82619dqb3a1lm97w9yqg"))))
(build-system python-build-system)
(propagated-inputs ; the following packages are all needed at run time
`(("python-cycler" ,python-cycler)