summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-08-12 00:13:17 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2018-08-12 20:15:34 +0200
commitfe0fb890ea41a8faec5192939eb974e0139fde13 (patch)
tree2a453d21a0eae826aec7c879828def1ee2161282 /gnu
parentfab8a9f9c33e889e70a3fb2358d986c72e17efc3 (diff)
downloadpatches-fe0fb890ea41a8faec5192939eb974e0139fde13.tar
patches-fe0fb890ea41a8faec5192939eb974e0139fde13.tar.gz
gnu: Add ghc-parsec-numbers.
* gnu/packages/haskell.scm (ghc-parsec-numbers): New public variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 7f14c59450..2673ca5e5d 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -1698,6 +1698,27 @@ School of Functional Programming', 1995. See
@uref{https://web.cecs.pdx.edu/~mpj/pubs/springschool.html, the paper}.")
(license license:bsd-3)))
+(define-public ghc-parsec-numbers
+ (package
+ (name "ghc-parsec-numbers")
+ (version "0.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "parsec-numbers/parsec-numbers-" version ".tar.gz"))
+ (sha256
+ (base32 "1gzy4v3r02kvdxvgg1nj83mmb6aph2v4ilf9c7y6nbvi2x49l0bp"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-parsec" ,ghc-parsec)))
+ (home-page "http://hackage.haskell.org/package/parsec-numbers")
+ (synopsis "Utilities for parsing numbers from strings")
+ (description
+ "This package provides the number parsers without the need to use a large
+(and unportable) token parser.")
+ (license license:bsd-3)))
+
(define-public ghc-paths
(package
(name "ghc-paths")