summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCarl Dong <contact@carldong.me>2020-04-06 14:02:42 -0400
committerCarl Dong <contact@carldong.me>2020-04-06 14:02:42 -0400
commitb066c25026f21fb57677aa34692a5034338e7ee3 (patch)
tree4a18f968187207c0eb61880f1c2bc1f533421205 /gnu
parent8a4608b4bf4f13766b4e3d11577c61f398034544 (diff)
downloadpatches-b066c25026f21fb57677aa34692a5034338e7ee3.tar
patches-b066c25026f21fb57677aa34692a5034338e7ee3.tar.gz
gnu: Move PACKAGES-WITH-*PATCHES to (guix packages)
* gnu/packages/cross-base.scm (package-with-extra-patches, package-with-patches): Move procedures from here... * guix/packages.scm (package-with-extra-patches, package-with-patches): ...to here, and export.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cross-base.scm12
1 files changed, 0 insertions, 12 deletions
diff --git a/gnu/packages/cross-base.scm b/gnu/packages/cross-base.scm
index ae3ac210b7..b0eb7ab4ed 100644
--- a/gnu/packages/cross-base.scm
+++ b/gnu/packages/cross-base.scm
@@ -70,18 +70,6 @@
`(cons ,(string-append "--target=" target)
,flags))))))
-(define (package-with-patches original patches)
- "Return package ORIGINAL with PATCHES applied."
- (package (inherit original)
- (source (origin (inherit (package-source original))
- (patches patches)))))
-
-(define (package-with-extra-patches original patches)
- "Return package ORIGINAL with all PATCHES appended to its list of patches."
- (package-with-patches original
- (append (origin-patches (package-source original))
- patches)))
-
(define (cross-binutils target)
"Return a cross-Binutils for TARGET."
(let ((binutils (package (inherit binutils)