summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrian Leung <bkleung89@gmail.com>2019-09-03 00:10:04 +0200
committerOleg Pykhalov <go.wigust@gmail.com>2019-09-03 23:00:34 +0300
commit8ac56556fe813e41f642bc4efc9b9696c2f3dc9e (patch)
treee0bb191ea25c13f01a5dfb4f2e8698861ca021d8 /gnu
parent7c6ebf28db77f1a78bddf3758472b4e99afcc99e (diff)
downloadpatches-8ac56556fe813e41f642bc4efc9b9696c2f3dc9e.tar
patches-8ac56556fe813e41f642bc4efc9b9696c2f3dc9e.tar.gz
gnu: emacs-org-pomodoro: Update to 2.1.0-1.aa07c11.
* gnu/packages/emacs-xyz.scm (emacs-org-pomodoro): Update to 2.1.0-1.aa07c11. [arguments]: Include "resources" directory and run tests. [source]: Update url. Signed-off-by: Oleg Pykhalov <go.wigust@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm64
1 files changed, 45 insertions, 19 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3f335737a2..29d9fe419f 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -4229,24 +4229,50 @@ number.")
(license license:gpl3+)))
(define-public emacs-org-pomodoro
- (package
- (name "emacs-org-pomodoro")
- (version "2.1.0")
- (source
- (origin
- (method git-fetch)
- (uri (git-reference
- (url "https://github.com/lolownia/org-pomodoro.git")
- (commit version)))
- (file-name (git-file-name name version))
- (sha256
- (base32 "0r5shgikm34d66i2hblyknbblpg92lb2zc9x4bcb28xkh7m9d0xv"))))
- (build-system emacs-build-system)
- (propagated-inputs
- `(("emacs-alert" ,emacs-alert)))
- (home-page "https://github.com/lolownia/org-pomodoro")
- (synopsis "Pomodoro technique for org-mode")
- (description "@code{emacs-org-pomodoro} adds very basic support for
+ ;; Last release version was from 2016.
+ (let ((commit "aa07c11318f91219336197e62c47bc7a3d090479")
+ (revision "1"))
+ (package
+ (name "emacs-org-pomodoro")
+ (version (git-version "2.1.0" revision commit))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/marcinkoziej/org-pomodoro.git")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0nbprh2nhnmb7ngp9ndr6zr37ashcsvpi5slv7a37x1dl7j6w1k4"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-alert" ,emacs-alert)))
+ (arguments
+ `(#:include (cons "^resources\\/" %default-include)
+ #:tests? #t
+ #:test-command '("emacs" "--batch"
+ "-l" "org-pomodoro-tests.el"
+ "-f" "ert-run-tests-batch-and-exit")
+ #:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'make-tests-writable
+ (lambda _
+ (make-file-writable "org-pomodoro-tests.el")
+ #t))
+ (add-before 'check 'add-require
+ (lambda _
+ (emacs-batch-edit-file "org-pomodoro-tests.el"
+ `(progn (progn (goto-char (point-min))
+ (re-search-forward
+ "ert-deftest")
+ (beginning-of-line)
+ (forward-line -1)
+ (insert "(require 'org-pomodoro)"))
+ (basic-save-buffer)))
+ #t)))))
+ (home-page "https://github.com/marcinkoziej/org-pomodoro")
+ (synopsis "Pomodoro technique for org-mode")
+ (description "@code{emacs-org-pomodoro} adds very basic support for
Pomodoro technique in Emacs org-mode.
Run @code{M-x org-pomodoro} for the task at point or select one of the
@@ -4254,7 +4280,7 @@ last tasks that you clocked time for. Each clocked-in pomodoro starts
a timer of 25 minutes and after each pomodoro a break timer of 5
minutes is started automatically. Every 4 breaks a long break is
started with 20 minutes. All values are customizable.")
- (license license:gpl3+)))
+ (license license:gpl3+))))
(define-public emacs-org-sidebar
(let ((commit "ed951d1e0d8b7e65ed35797403fd3e8c88f507f5")