summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBen Woodcroft <donttrustben@gmail.com>2018-10-21 22:31:56 +1000
committerBen Woodcroft <donttrustben@gmail.com>2018-10-21 22:31:56 +1000
commit617c478506888daea35dceeda3679196eb8a5177 (patch)
tree37829911b74d56b9fb9e3c0b8cb9afb813c10788 /gnu
parent21c837405a7d46590fbe1d9e45e16a56f182e451 (diff)
downloadpatches-617c478506888daea35dceeda3679196eb8a5177.tar
patches-617c478506888daea35dceeda3679196eb8a5177.tar.gz
gnu: python2-dendropy: Disable failing test.
* gnu/packages/bioinformatics.scm (python2-dendropy)[arguments]: Disable failing test.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/bioinformatics.scm16
1 files changed, 15 insertions, 1 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 7c58ab2455..1e04081ceb 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -2063,7 +2063,21 @@ trees (phylogenies) and characters.")
(license license:bsd-3)))
(define-public python2-dendropy
- (package-with-python2 python-dendropy))
+ (let ((base (package-with-python2 python-dendropy)))
+ (package
+ (inherit base)
+ (arguments
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'remove-failing-test
+ (lambda _
+ ;; This test fails when the full test suite is run, as documented
+ ;; at https://github.com/jeetsukumaran/DendroPy/issues/74
+ (substitute* "tests/test_dataio_nexml_reader_tree_list.py"
+ (("test_collection_comments_and_annotations")
+ "do_not_test_collection_comments_and_annotations"))
+ #t)))
+ ,@(package-arguments base))))))
(define-public python-py2bit
(package