summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrice Waegeneire <brice@waegenei.re>2020-02-09 10:38:42 +0100
committerLudovic Courtès <ludo@gnu.org>2020-02-14 23:01:47 +0100
commit0c26e43ecacb5885d4ea59dcc9b118db192f2828 (patch)
tree30fdd11be9a47beb86656426ddb0eb4bec0d847d /gnu
parent8cd2a395c7f2b4a607101ba2c9a3b8e47477e5a8 (diff)
downloadpatches-0c26e43ecacb5885d4ea59dcc9b118db192f2828.tar
patches-0c26e43ecacb5885d4ea59dcc9b118db192f2828.tar.gz
gnu: btrfs-progs: Install udev-rules.
* gnu/packages/linux.scm (btrfs-progs)[arguments]: Add phase patch-makefile. [native-inputs]: Add lvm2, eudev. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index d1ce205194..c5e27a07db 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -4037,6 +4037,13 @@ and copy/paste text in the console and in xterm.")
"static")) ; static versions of the binaries in "out"
(arguments
'(#:phases (modify-phases %standard-phases
+ (add-after 'unpack 'patch-makefile
+ (lambda* (#:key outputs #:allow-other-keys)
+ (substitute* "Makefile"
+ (("\\$\\(DESTDIR\\)\\$\\(udevruledir\\)")
+ (string-append (assoc-ref outputs "out")
+ "/lib/udev/rules.d")))
+ #t))
(add-after 'build 'build-static
(lambda _ (invoke "make" "static")))
(add-after 'install 'install-bash-completion
@@ -4057,7 +4064,7 @@ and copy/paste text in the console and in xterm.")
#:tests? #f ; XXX: require the 'btrfs' kernel module.
#:test-target "test"
#:parallel-tests? #f)) ; tests fail when run in parallel
- (inputs `(("e2fsprogs" ,e2fsprogs)
+ (inputs `(("e2fsprogs" ,e2fsprogs) ; for btrfs-convert
("libblkid" ,util-linux)
("libblkid:static" ,util-linux "static")
("libuuid" ,util-linux)
@@ -4077,6 +4084,8 @@ and copy/paste text in the console and in xterm.")
;; For tests.
("acl" ,acl)
("which" ,which)
+ ("dmsetup" ,lvm2)
+ ("udevadm" ,eudev)
;; The tests need 'grep' with perl regexp support.
("grep" ,grep)))
(home-page "https://btrfs.wiki.kernel.org/index.php/Main_Page")