summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorpimi <madalinionel.patrascu@mdc-berlin.de>2018-08-29 09:32:45 +0200
committerLudovic Courtès <ludo@gnu.org>2018-09-07 11:40:06 +0200
commitcadc10a513af2624c9233fb2cffb4c4ff5471197 (patch)
tree326f40cf1574de6d94d58cf86e4ef1c090da2b4f /gnu
parent40c10917bc3b8df853001c193da882d643db1bd1 (diff)
downloadpatches-cadc10a513af2624c9233fb2cffb4c4ff5471197.tar
patches-cadc10a513af2624c9233fb2cffb4c4ff5471197.tar.gz
gnu: Add r-abcrf.
* gnu/packages/cran.scm (r-abcrf): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index c713a9904b..93c111bccc 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -5432,3 +5432,31 @@ colony optimization algorithm @url{http://mf.erciyes.edu.tr/abc/pub/tr06_2005.pd
Poisson, and Gamma distribution and estimates the proportional paternity of the
second male (P2) based on the best fit distribution.")
(license license:gpl2)))
+
+(define-public r-abcrf
+ (package
+ (name "r-abcrf")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "abcrf" version))
+ (sha256
+ (base32 "06vy3inikrr9hv36q4djhrgzi9zizdfnhz17wpra8kadmr7qj441"))))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-mass" ,r-mass)
+ ("r-matrixstats" ,r-matrixstats)
+ ("r-ranger" ,r-ranger)
+ ("r-rcpp" ,r-rcpp)
+ ("r-rcpparmadillo" ,r-rcpparmadillo)
+ ("r-readr" ,r-readr)
+ ("r-stringr" ,r-stringr)))
+ (home-page "https://cran.r-project.org/web/packages/abcrf/")
+ (synopsis "Approximate bayesian computation via random forests")
+ (description
+ "This package performs approximate bayesian computation (ABC) model choice and
+parameter inference via random forests. This machine learning tool named random
+forests (RF) can conduct selection among the highly complex models covered by
+ABC algorithms.")
+ (license license:gpl2+)))