summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:09:54 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-15 05:11:31 +0200
commit6aade73967c321b8c8818b63728708e20cd122bc (patch)
treef16018537638a541751e4f8dbaa00cd107a4900c /gnu
parentde957d959545ed25567916060222121140b8547f (diff)
downloadpatches-6aade73967c321b8c8818b63728708e20cd122bc.tar
patches-6aade73967c321b8c8818b63728708e20cd122bc.tar.gz
gnu: camlp5: Don't use unstable tarball.
* gnu/packages/ocaml.scm (camlp5)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ocaml.scm17
1 files changed, 9 insertions, 8 deletions
diff --git a/gnu/packages/ocaml.scm b/gnu/packages/ocaml.scm
index 2a2a052de5..a565b2e01d 100644
--- a/gnu/packages/ocaml.scm
+++ b/gnu/packages/ocaml.scm
@@ -647,14 +647,15 @@ syntax of OCaml.")
(package
(name "camlp5")
(version "7.07")
- (source (origin
- (method url-fetch)
- (uri (string-append "https://github.com/camlp5/camlp5/archive/rel"
- (string-delete #\. version) ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
- (sha256
- (base32
- "148r6p93xlxi6v7kbsqv8i70r6av04cyn0109pwss5xj6fw97i52"))))
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/camlp5/camlp5.git")
+ (commit (string-append "rel" (string-delete #\. version)))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1c8v45553ccbqha2ypfranqlgw06rr5wjr2hlnrx5bf9jfq0h0dn"))))
(build-system gnu-build-system)
(inputs
`(("ocaml" ,ocaml)))