summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2019-11-23 19:21:07 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2019-12-10 17:28:46 +0100
commit4e75911011b2715d9ea1d4750ec989d483abfd4b (patch)
treec1f4e8c2f29b7d4ea8119979b2e827c720655a0b /gnu
parentf114a689e70103dd7d00015663193d0b5f82f52e (diff)
downloadpatches-4e75911011b2715d9ea1d4750ec989d483abfd4b.tar
patches-4e75911011b2715d9ea1d4750ec989d483abfd4b.tar.gz
gnu: Add knavalbattle.
* gnu/packages/games.scm (knavalbattle): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm42
1 files changed, 42 insertions, 0 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 01834c1581..b06738f575 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -9320,3 +9320,45 @@ stay in game the higher will your score be.
This package is part of the KDE games module.")
(license (list license:gpl2+ license:fdl1.2+))))
+
+(define-public knavalbattle
+ (package
+ (name "knavalbattle")
+ (version "19.08.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "mirror://kde/stable/applications/" version
+"/src/knavalbattle-" version ".tar.xz"))
+ (sha256
+ (base32 "0sdfjplqkb30x2mvh66pkzay6vn5px87779sh2s8lpl6fcw0v9g4"))))
+ (properties `((tags . ("Desktop" "KDE" "Games"))))
+ (build-system qt-build-system)
+ (native-inputs
+ `(("extra-cmake-modules" ,extra-cmake-modules)
+ ("kdoctools" ,kdoctools)))
+ (inputs
+ `(("kauth" ,kauth)
+ ("kcompletion" ,kcompletion)
+ ("kconfig" ,kconfig)
+ ("kconfigwidgets" ,kconfigwidgets)
+ ("kcoreaddons" ,kcoreaddons)
+ ("kcrash" ,kcrash)
+ ("kdbusaddons" ,kdbusaddons)
+ ("kdnssd" ,kdnssd)
+ ("ki18n" ,ki18n)
+ ("ktextwidgets" ,ktextwidgets)
+ ("kxmlgui" ,kxmlgui)
+ ("libkdegames" ,libkdegames)
+ ("qtbase" ,qtbase)
+ ("qtdeclarative" ,qtdeclarative)))
+ (home-page "https://games.kde.org/")
+ (synopsis "Battleship board game with built-in game server")
+ (description "KBattleship is a Battle Ship game for KDE.
+
+Ships are placed on a board which represents the sea. Players try to hit each
+others ships in turns without knowing where they are placed. The first player
+to destroy all ships wins the game.
+
+This package is part of the KDE games module.")
+ (license (list license:gpl2+ license:fdl1.2+))))