summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-19 11:53:47 +0200
committerRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2015-05-21 11:54:46 +0200
commit9099e881828fd242cc26054c0f33670c46154d96 (patch)
tree5d517d12abad57aa2c296f9d993cc8f1fdb2fc7b /gnu
parentafb925175e6294f65295a1d7d3aebf283b9620fb (diff)
downloadpatches-9099e881828fd242cc26054c0f33670c46154d96.tar
patches-9099e881828fd242cc26054c0f33670c46154d96.tar.gz
gnu: r: Apply patch to fix linking against R.
* gnu/packages/patches/r-fix-15899.patch: New file. * gnu-system.am (dist_patch_DATA): Add it. * gnu/packages/statistics.scm (r)[source]: Use it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/patches/r-fix-15899.patch17
-rw-r--r--gnu/packages/statistics.scm3
2 files changed, 19 insertions, 1 deletions
diff --git a/gnu/packages/patches/r-fix-15899.patch b/gnu/packages/patches/r-fix-15899.patch
new file mode 100644
index 0000000000..40593d34e6
--- /dev/null
+++ b/gnu/packages/patches/r-fix-15899.patch
@@ -0,0 +1,17 @@
+Without the "extern" keyword external applications linking against R (such as
+Shogun, for example) might not be linkable.
+
+See https://bugs.r-project.org/bugzilla3/show_bug.cgi?id=15899 for details
+about this bug.
+
+--- a/src/include/Rinterface.h (revision 66251)
++++ b/src/include/Rinterface.h (working copy)
+@@ -84,7 +84,7 @@
+ void fpu_setup(Rboolean);
+
+ /* in unix/system.c */
+-int R_running_as_main_program;
++extern int R_running_as_main_program;
+
+ #ifdef CSTACK_DEFNS
+ /* duplicating Defn.h */
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 722e0dfa49..9408705d5e 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -50,7 +50,8 @@
version ".tar.gz"))
(sha256
(base32
- "0dagyqgvi8i3nw158qi2zpwm04s4ffzvnmk5niaksvxs30zrbbpm"))))
+ "0dagyqgvi8i3nw158qi2zpwm04s4ffzvnmk5niaksvxs30zrbbpm"))
+ (patches (list (search-patch "r-fix-15899.patch")))))
(build-system gnu-build-system)
(arguments
`(#:make-flags