summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-04-09 00:01:37 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-04-11 05:42:40 +0200
commit1a04d421951eea118c1a9fe523d49c096b054386 (patch)
tree0cc5d6032cfe84680389de0744187203bcc7ca9c /gnu
parent1961d18791d3d929889471ab5cc1676cba0e33a1 (diff)
downloadpatches-1a04d421951eea118c1a9fe523d49c096b054386.tar
patches-1a04d421951eea118c1a9fe523d49c096b054386.tar.gz
gnu: python-flasgger: Don't use unstable tarball.
* gnu/packages/python-xyz.scm (python-flasgger)[source]: Use GIT-FETCH and GIT-FILE-NAME.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index 5b3d475e46..2a000ec26c 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -12590,13 +12590,13 @@ Swagger 2.0).")
(version "0.6.3")
(source
(origin
- (method url-fetch)
- (uri (string-append "https://github.com/rochacbruno/flasgger/archive/"
- version ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/rochacbruno/flasgger.git")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
- (base32
- "1gqzlm0rb55fdpsy5ipkganlx9cnpi454fqyycr03jm22zql14ay"))))
+ (base32 "0yydxsyjnc0clbrjqb1n7587l6cdqvwdagwxk5hkx01qwdfbkvpn"))))
(build-system python-build-system)
(arguments
`(#:phases