summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorZzull <bstrazzull@hotmail.fr>2019-06-15 20:48:43 +0200
committerLudovic Courtès <ludo@gnu.org>2019-06-18 16:55:01 +0200
commite6e2f4a08dce2bb2f8d1e1db58e49dfb1e55131a (patch)
tree8e115b0bf44e7f9489d9f4fa20032c825028240d /gnu
parent0c212811ac5cdfd6bcdfd4e7eb82571bbd6e33d5 (diff)
downloadpatches-e6e2f4a08dce2bb2f8d1e1db58e49dfb1e55131a.tar
patches-e6e2f4a08dce2bb2f8d1e1db58e49dfb1e55131a.tar.gz
gnu: Add emacs-gruvbox-theme
* gnu/packages/emacs-xyz.scm (emacs-gruvbox-theme): New variable Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm28
1 files changed, 28 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 3ef69ab9e0..719c729f62 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -48,6 +48,7 @@
;;; Copyright © 2019 Gabriel Hondet <gabrielhondet@gmail.com>
;;; Copyright © 2019 LaFreniere, Joseph <joseph@lafreniere.xyz>
;;; Copyright © 2019 Amar Singh <nly@disroot.org>
+;;; Copyright © 2019 Baptiste Strazzulla <bstrazzull@hotmail.fr>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -4081,6 +4082,33 @@ transparent background. If you load it from a GUI, it will default to a
dark background.")
(license license:gpl3+)))
+(define-public emacs-gruvbox-theme
+ (package
+ (name "emacs-gruvbox-theme")
+ (version "1.28.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/greduan/emacs-theme-gruvbox.git")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "00qq92gp1g55pzm97rh7k0dgxy44pxziridl8kqm4rbpi31r7k9p"))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-autothemer" ,emacs-autothemer)))
+ (home-page "https://github.com/greduan/emacs-theme-gruvbox")
+ (synopsis "Gruvbox is a retro groove color scheme ported from Vim")
+ (description
+ "Gruvbox is heavily inspired by badwolf, jellybeans and solarized.
+
+Designed as a bright theme with pastel 'retro groove' colors and light/dark
+mode switching in the way of solarized. The main focus when developing gruvbox
+is to keep colors easily distinguishable, contrast enough and still pleasant
+for the eyes.")
+ (license license:expat))) ; MIT license
+
(define-public emacs-2048-game
(package
(name "emacs-2048-game")