summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-09-28 18:31:03 +1000
committerChristopher Baines <mail@cbaines.net>2017-09-30 11:46:09 +0100
commitcb6bc5df1ce388ce88d6d78e8163b430c86509fa (patch)
treeea765d77e69f4e8c69ade47c06f323b7c645b90d /gnu
parent268643b94ab42bfc68fa940e774b7b47bf3a5ba8 (diff)
downloadpatches-cb6bc5df1ce388ce88d6d78e8163b430c86509fa.tar
patches-cb6bc5df1ce388ce88d6d78e8163b430c86509fa.tar.gz
gnu: Add ruby-rubyzip.
* gnu/packages/ruby.scm (ruby-rubyzip): New variable. Co-authored by Ben Woodcroft <donttrustben@gmail.com>.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index 3b0a67b9da..0193076291 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -1001,6 +1001,41 @@ Ruby Gems.")
(home-page "https://github.com/postmodern/rubygems-tasks")
(license license:expat)))
+(define-public ruby-rubyzip
+ (package
+ (name "ruby-rubyzip")
+ (version "1.2.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "rubyzip" version))
+ (sha256
+ (base32
+ "06js4gznzgh8ac2ldvmjcmg9v1vg9llm357yckkpylaj6z456zqz"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-tests
+ (lambda* (#:key inputs #:allow-other-keys)
+ (substitute* "test/gentestfiles.rb"
+ (("/usr/bin/zip")
+ (string-append
+ (assoc-ref inputs "zip") "/bin/zip")))
+ (substitute* "test/input_stream_test.rb"
+ (("/usr/bin/env ruby") (which "ruby")))
+ #t)))))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-simplecov" ,ruby-simplecov)
+ ("zip" ,zip)
+ ("unzip" ,unzip)))
+ (synopsis "Ruby module is for reading and writing zip files")
+ (description
+ "The rubyzip module provides ways to read from and create zip files.")
+ (home-page "http://github.com/rubyzip/rubyzip")
+ (license license:bsd-2)))
+
(define-public ruby-ffi
(package
(name "ruby-ffi")