summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:12:06 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:33 +0100
commit35182fa2b429a2bc12cfb86829b398835d1e41ee (patch)
treecf709e816e07ebc7e31752e49dfdb63801271bb0 /gnu
parent354902e441e7d200238ff0a3f2781b6789c5bc5b (diff)
downloadpatches-35182fa2b429a2bc12cfb86829b398835d1e41ee.tar
patches-35182fa2b429a2bc12cfb86829b398835d1e41ee.tar.gz
gnu: Add ghc-haddock-test.
* gnu/packages/haskell.scm (ghc-haddock-test): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 951e122299..5d85952ab7 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -694,6 +694,28 @@ the ‘haddock’ package.")
documentation-generation tool for Haskell libraries.")
(license license:bsd-3)))
+(define-public ghc-haddock-test
+ (package
+ (name "ghc-haddock-test")
+ (version "0.0.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (string-append "https://hackage.haskell.org/package/"
+ "haddock-test/haddock-test-"
+ version ".tar.gz"))
+ (sha256
+ (base32
+ "1ax8fnfrwx66csj952f3virxzapipan9da7z5l1zc12nqkifbs7w"))))
+ (build-system haskell-build-system)
+ (inputs
+ `(("ghc-xml" ,ghc-xml)
+ ("ghc-syb" ,ghc-syb)))
+ (home-page "http://www.haskell.org/haddock/")
+ (synopsis "Test utilities for Haddock")
+ (description "This package provides test utilities for Haddock.")
+ (license license:bsd-3)))
+
(define-public ghc-haddock
(package
(name "ghc-haddock")