summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorChristopher Baines <mail@cbaines.net>2017-09-22 20:15:29 +0100
committerChristopher Baines <mail@cbaines.net>2017-09-30 11:46:09 +0100
commit268643b94ab42bfc68fa940e774b7b47bf3a5ba8 (patch)
treef40a231a877516c075d716e787a10fa37d60270d /gnu
parent823ed0972ff8022b87337ec74c8ef41dc8bfbec3 (diff)
downloadpatches-268643b94ab42bfc68fa940e774b7b47bf3a5ba8.tar
patches-268643b94ab42bfc68fa940e774b7b47bf3a5ba8.tar.gz
gnu: Add ruby-progress_bar.
* gnu/packages/ruby.scm (ruby-progress_bar): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/ruby.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index d6aa59099c..3b0a67b9da 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -2111,6 +2111,37 @@ for select languages.")
(home-page "http://coderay.rubychan.de")
(license license:expat)))
+(define-public ruby-progress_bar
+ (package
+ (name "ruby-progress_bar")
+ (version "1.1.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (rubygems-uri "progress_bar" version))
+ (sha256
+ (base32
+ "1qc40mr6p1z9a3vlpnsg1zfgk1qswviql2a31y63wpv3vr6b5f48"))))
+ (build-system ruby-build-system)
+ (arguments
+ '(#:test-target "spec"))
+ (propagated-inputs
+ `(("ruby-highline" ,ruby-highline)
+ ("ruby-options" ,ruby-options)))
+ (native-inputs
+ `(("bundler" ,bundler)
+ ("ruby-rspec" ,ruby-rspec)
+ ("ruby-timecop" ,ruby-timecop)))
+ (synopsis
+ "Ruby library for displaying progress bars")
+ (description
+ "ProgressBar is a simple library for displaying progress bars. The
+maximum value is configurable, and additional information can be displayed
+like the percentage completion, estimated time remaining, elapsed time and
+rate.")
+ (home-page "https://github.com/paul/progress_bar")
+ (license license:wtfpl2)))
+
(define-public ruby-pry
(package
(name "ruby-pry")