summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:43:39 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commit22b439dbb6fdb4064de3c7be8aef045c99f3a282 (patch)
tree4b1cf1587aecb034c0365aefe609719a4606a794 /gnu
parent29addb279a4e28dd54cd5ad71f74fad7907997d6 (diff)
downloadpatches-22b439dbb6fdb4064de3c7be8aef045c99f3a282.tar
patches-22b439dbb6fdb4064de3c7be8aef045c99f3a282.tar.gz
gnu: ghc-cgi: Update to 3001.3.0.2.
* gnu/packages/haskell.scm (ghc-cgi): Update to 3001.3.0.2. [arguments]: Allow building with newer QuickCheck. [inputs]: Remove ghc-old-locale and ghc-old-time. [native-inputs]: Add ghc-doctest and ghc-quickcheck.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm11
1 files changed, 7 insertions, 4 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index 83e3c7f8f9..2f6f47ca75 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -831,7 +831,7 @@ tool lex or flex for C/C++.")
(define-public ghc-cgi
(package
(name "ghc-cgi")
- (version "3001.3.0.1")
+ (version "3001.3.0.2")
(source
(origin
(method url-fetch)
@@ -841,17 +841,20 @@ tool lex or flex for C/C++.")
".tar.gz"))
(sha256
(base32
- "0lj7ri198r6fxz8zyc0vzpm7mx66794zxi9siffhh119qw8931cn"))))
+ "1hbpplss1m4rdpm4ibip6fpimlhssqa14fl338kl2jbc463i64cj"))))
(build-system haskell-build-system)
+ (arguments
+ `(#:configure-flags (list "--allow-newer=QuickCheck")))
(inputs
`(("ghc-parsec" ,ghc-parsec)
- ("ghc-old-locale" ,ghc-old-locale)
- ("ghc-old-time" ,ghc-old-time)
("ghc-exceptions" ,ghc-exceptions)
("ghc-multipart" ,ghc-multipart)
("ghc-network-uri" ,ghc-network-uri)
("ghc-network" ,ghc-network)
("ghc-mtl" ,ghc-mtl)))
+ (native-inputs
+ `(("ghc-doctest" ,ghc-doctest)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
(home-page
"https://github.com/cheecheeo/haskell-cgi")
(synopsis "Library for writing CGI programs")