summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-08-15 10:30:33 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-08-15 10:31:20 +0300
commit3837108e403d385cd0b616fb601b9942c8bb213f (patch)
tree3a8d0af86f7826e0006d9283bc0b5d3af59068e1 /gnu
parent2d430f29231d0d817459d86e0fe15089372e9547 (diff)
downloadpatches-3837108e403d385cd0b616fb601b9942c8bb213f.tar
patches-3837108e403d385cd0b616fb601b9942c8bb213f.tar.gz
gnu: bcftools: Fix building on aarch64.
* gnu/packages/patches/bcftools-regidx-unsigned-char.patch: New file. * gnu/packages/bioinformatics.scm (bcftools)[source]: Use it. * gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/bioinformatics.scm1
-rw-r--r--gnu/packages/patches/bcftools-regidx-unsigned-char.patch16
3 files changed, 18 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index b15a16b6bc..2ab6901d8a 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -527,6 +527,7 @@ dist_patch_DATA = \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/azr3.patch \
%D%/packages/patches/bash-completion-directories.patch \
+ %D%/packages/patches/bcftools-regidx-unsigned-char.patch \
%D%/packages/patches/binutils-ld-new-dtags.patch \
%D%/packages/patches/binutils-loongson-workaround.patch \
%D%/packages/patches/binutils-mips-bash-bug.patch \
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9d64294e48..17cd214a33 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -311,6 +311,7 @@ BAM files.")
(sha256
(base32
"0093hkkvxmbwfaa7905s6185jymynvg42kq6sxv7fili11l5mxwz"))
+ (patches (search-patches "bcftools-regidx-unsigned-char.patch"))
(modules '((guix build utils)))
(snippet
;; Delete bundled htslib.
diff --git a/gnu/packages/patches/bcftools-regidx-unsigned-char.patch b/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
new file mode 100644
index 0000000000..af5bc160f5
--- /dev/null
+++ b/gnu/packages/patches/bcftools-regidx-unsigned-char.patch
@@ -0,0 +1,16 @@
+Description: Fix test-regidx argument parsing on archs with unsigned char
+ On architectures where char is unsigned "c >= 0" was always true.
+Author: Adrian Bunk <bunk@debian.org>
+Bug-Debian: https://bugs.debian.org/865060
+
+--- a/test/test-regidx.c
++++ b/test/test-regidx.c
+@@ -336,7 +336,7 @@
+ {"seed",1,0,'s'},
+ {0,0,0,0}
+ };
+- char c;
++ int c;
+ int seed = (int)time(NULL);
+ while ((c = getopt_long(argc, argv, "hvs:",loptions,NULL)) >= 0)
+ {