summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-12-31 22:33:33 -0500
committerMark H Weaver <mhw@netris.org>2019-01-01 11:22:55 -0500
commitce899af10901bf9ed06fe0528b8c4f628ebba4fd (patch)
tree5e87ab3ff1dafd2a4ef39b321c0e9f1baceb32a1 /gnu
parent3fb7b61250dde547204f17a0cd6c3bad12038e40 (diff)
downloadpatches-ce899af10901bf9ed06fe0528b8c4f628ebba4fd.tar
patches-ce899af10901bf9ed06fe0528b8c4f628ebba4fd.tar.gz
gnu: linux-libre: Build with GCC-7 on all systems.
* gnu/packages/linux.scm (make-linux-libre)[native-inputs]: Include GCC-7 unconditionally. Previously it was included only on Intel systems. Add GMP, MPFR, and MPC. [arguments]: Add 'work-around-gcc-7-include-path-issue' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/linux.scm21
1 files changed, 14 insertions, 7 deletions
diff --git a/gnu/packages/linux.scm b/gnu/packages/linux.scm
index 177752b0db..982fbe56aa 100644
--- a/gnu/packages/linux.scm
+++ b/gnu/packages/linux.scm
@@ -306,14 +306,16 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
("elfutils" ,elfutils) ; Needed to enable CONFIG_STACK_VALIDATION
("flex" ,flex)
("bison" ,bison)
- ;; On x86, build with GCC-7 for full retpoline support.
+
+ ;; Build with GCC-7 for full retpoline support.
;; FIXME: Remove this when our default compiler has retpoline support.
- ,@(match (system->linux-architecture
- (or (%current-target-system) (%current-system)))
- ((or "x86_64" "i386")
- `(("gcc" ,gcc-7)))
- (_
- '()))
+ ("gcc" ,gcc-7)
+
+ ;; These are needed to compile the GCC plugins.
+ ("gmp" ,gmp)
+ ("mpfr" ,mpfr)
+ ("mpc" ,mpc)
+
,@(match (and configuration-file
(configuration-file
(system->linux-architecture
@@ -335,6 +337,11 @@ for ARCH and optionally VARIANT, or #f if there is no such configuration."
(substitute* (find-files "." "^Makefile(\\.include)?$")
(("/bin/pwd") "pwd"))
#t))
+ (add-before 'configure 'work-around-gcc-7-include-path-issue
+ (lambda _
+ (unsetenv "C_INCLUDE_PATH")
+ (unsetenv "CPLUS_INCLUDE_PATH")
+ #t))
(replace 'configure
(lambda* (#:key inputs native-inputs target #:allow-other-keys)
;; Avoid introducing timestamps