summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-07-17 10:49:09 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-07-17 10:49:18 +0300
commit9a0d324a1629145a64c6f28082843564d66c6bcc (patch)
tree58c9f890e0a060bb0bcd1ac1390dbe96f4a11ec7 /gnu
parent2d4514e92c346820219e5c03e9e455e9f0f74e35 (diff)
downloadpatches-9a0d324a1629145a64c6f28082843564d66c6bcc.tar
patches-9a0d324a1629145a64c6f28082843564d66c6bcc.tar.gz
gnu: angband: Update to 4.1.2.
* gnu/packages/games.scm (angband): Update to 4.1.2. [source]: Parameterize source uri. [arguments]: Use custom 'autogen.sh phase to replace 'bootstrap phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm13
1 files changed, 7 insertions, 6 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 4af0b52e82..a3c770a0ba 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -955,15 +955,16 @@ that beneath its ruins lay buried an ancient evil.")
(define-public angband
(package
(name "angband")
- (version "4.0.5")
+ (version "4.1.2")
(source
(origin
(method url-fetch)
- (uri (string-append "http://rephial.org/downloads/4.0/"
- "angband-" version ".tar.gz"))
+ (uri (string-append "http://rephial.org/downloads/"
+ (version-major+minor version)
+ "/angband-" version ".tar.gz"))
(sha256
(base32
- "0lpq2kms7hp421vrasx2bkkn9w08kr581ldwik3v0hlq6h7rlxhd"))
+ "0ahfzb66ihxvkxcbhcib816x40sdsp26b3ravr1xqp44w1whkg1h"))
(modules '((guix build utils)))
(snippet
;; So, some of the sounds/graphics/tilesets are under different
@@ -987,11 +988,11 @@ that beneath its ruins lay buried an ancient evil.")
#:configure-flags (list (string-append "--bindir=" %output "/bin"))
#:phases
(modify-phases %standard-phases
- (add-after 'unpack 'autogen.sh
+ (replace 'bootstrap
(lambda _
(substitute* "acinclude.m4"
(("ncursesw5-config") "ncursesw6-config"))
- (zero? (system* "sh" "autogen.sh")))))))
+ (invoke "sh" "autogen.sh"))))))
(native-inputs
`(("autoconf" ,autoconf)
("automake" ,automake)))