summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2013-12-14 13:50:37 +0100
committerAndreas Enge <andreas@enge.fr>2013-12-14 13:51:54 +0100
commit98a046cd2520e643e77daaded7a0271efcd9658e (patch)
tree8cc43fd7d89efce3a1e346028eaa223a9c06ea28 /gnu
parente93c24df09d2b5ce453734d4d6d1b3d1012d628d (diff)
downloadpatches-98a046cd2520e643e77daaded7a0271efcd9658e.tar
patches-98a046cd2520e643e77daaded7a0271efcd9658e.tar.gz
gnu: icecat: Further analyse the failure of using system libpng and libjpeg.
* gnu/packages/gnuzilla.scm (icecat): Add comments.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gnuzilla.scm23
1 files changed, 16 insertions, 7 deletions
diff --git a/gnu/packages/gnuzilla.scm b/gnu/packages/gnuzilla.scm
index 8a0e23e451..67e451d911 100644
--- a/gnu/packages/gnuzilla.scm
+++ b/gnu/packages/gnuzilla.scm
@@ -66,8 +66,6 @@
("gst-plugins-base" ,gst-plugins-base-0.10)
("gtk+" ,gtk+-2)
("libevent" ,libevent)
- ;; ("libpng" ,libpng)
- ;; ("libjpeg" ,libjpeg)
("libxt" ,libxt)
("libffi" ,libffi)
("mesa" ,mesa)
@@ -92,13 +90,24 @@
"--with-system-bz2" ; FIXME: not used
"--with-system-libevent"
- ;; TODO: Currently fails with "--with-system-png
- ;; won't work because the system's libpng doesn't
- ;; have APNG support".
+ ;; Fails with "--with-system-png won't work because
+ ;; the system's libpng doesn't have APNG support".
+ ;; According to
+ ;; http://sourceforge.net/projects/libpng-apng/ ,
+ ;; "the Animated Portable Network Graphics (APNG)
+ ;; is an unofficial extension of the Portable
+ ;; Network Graphics (PNG) format";
+ ;; we probably do not wish to support it.
;; "--with-system-png"
- ;; TODO: Currently fails with "Insufficient JPEG
- ;; library version for --with-system-jpeg".
+ ;; Fails with "libjpeg-turbo JCS_EXTENSIONS
+ ;; required".
+ ;; According to
+ ;; http://sourceforge.net/projects/libjpeg-turbo/ ,
+ ;; "libjpeg-turbo is a derivative of libjpeg that
+ ;; uses MMX, SSE, SSE2, and NEON SIMD instructions
+ ;; to accelerate baseline JPEG compression/
+ ;; decompression", so we had better not use it
;; "--with-system-jpeg"
"--enable-system-ffi")