summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-07-13 13:06:14 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-07-24 09:46:46 +0200
commit5f50dd95806f12f4f17c5112214114893ac22b99 (patch)
tree62d3227d7e1783eac2677934cfbd9a0de0146141 /gnu
parente80ecb7bf203a5178a4cebf1ef9a7b4da6906e2a (diff)
downloadpatches-5f50dd95806f12f4f17c5112214114893ac22b99.tar
patches-5f50dd95806f12f4f17c5112214114893ac22b99.tar.gz
gnu: Add texlive-hyphen-turkmen.
* gnu/packages/tex.scm (texlive-hyphen-turkmen): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tex.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/tex.scm b/gnu/packages/tex.scm
index 74d67c7a88..8e99835d90 100644
--- a/gnu/packages/tex.scm
+++ b/gnu/packages/tex.scm
@@ -2250,6 +2250,41 @@ fit into EC encoding, so support for Ottoman Turkish had to be dropped to keep
compatibility with 8-bit engines.")
(license license:lppl1.0+))))
+(define-public texlive-hyphen-turkmen
+ (let ((template (texlive-hyphen-package
+ "texlive-hyphen-turkmen" "tk"
+ (list "/source/generic/hyph-utf8/languages/tk/generate_patterns_tk.rb")
+ (base32
+ "1wlqx8wb0wsqhdv823brc3i8w1vf4m4bkb2vg917j5dq8p8p71aw"))))
+ (package
+ (inherit template)
+ (arguments
+ (substitute-keyword-arguments (package-arguments template)
+ ((#:phases phases)
+ `(modify-phases ,phases
+ (add-before 'build 'build-patterns
+ (lambda _
+ (let ((target (string-append (getcwd)
+ "/tex/generic/hyph-utf8/patterns/tex")))
+ (mkdir-p target)
+ (with-directory-excursion "source/generic/hyph-utf8/languages/tk/"
+ (substitute* "generate_patterns_tk.rb"
+ (("\\$file = File.new.*")
+ (string-append "$file = File.new(\"" target
+ "/hyph-tr.tex\",\"w\")\n")))
+ (invoke "ruby" "generate_patterns_tk.rb"))
+ #t)))
+ (add-after 'install 'install-hyph-tk.tex
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref outputs "out"))
+ (target (string-append out "/share/texmf-dist/tex")))
+ (copy-recursively "tex" target)
+ #t)))))))
+ (synopsis "Hyphenation patterns for Turkmen")
+ (description "The package provides hyphenation patterns for Turkmen in
+T1/EC and UTF-8 encodings.")
+ (license license:public-domain))))
+
(define-public texlive-hyph-utf8
(package
(inherit (simple-texlive-package