summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-03-17 09:01:13 +0200
committerEfraim Flashner <efraim@flashner.co.il>2020-03-22 09:58:28 +0200
commit2eb09a5cfdbf2fc1a1515ffee828a2b541323f28 (patch)
tree0577af54a26ac2b13e578fa2a65a3281c24b63f6 /gnu
parent9a684b4078ef4bc05b3fd18ae5ca8235db66c910 (diff)
downloadpatches-2eb09a5cfdbf2fc1a1515ffee828a2b541323f28.tar
patches-2eb09a5cfdbf2fc1a1515ffee828a2b541323f28.tar.gz
gnu: Add python-fusepyng.
* gnu/packages/python-xyz.scm (python-fusepyng): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm33
1 files changed, 33 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index c47dac8245..d006b2a1b6 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -16049,6 +16049,39 @@ MacFUSE. The binding is created using the standard @code{ctypes} library.")
(define-public python2-fusepy
(package-with-python2 python-fusepy))
+(define-public python-fusepyng
+ (package
+ (name "python-fusepyng")
+ (version "1.0.7")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "fusepyng" version))
+ (sha256
+ (base32
+ "17w9iw6m6zjbmnhs4ikd27pq4mb1nan6k4ahlwyz40463vw6wkwb"))))
+ (build-system python-build-system)
+ (arguments
+ '(#:phases
+ (modify-phases %standard-phases
+ (add-after 'unpack 'set-libfuse-path
+ (lambda* (#:key inputs #:allow-other-keys)
+ (let ((fuse (assoc-ref inputs "fuse")))
+ (substitute* "fusepyng.py"
+ (("os.environ.get\\('FUSE_LIBRARY_PATH'\\)")
+ (string-append "\"" fuse "/lib/libfuse.so\""))))
+ #t)))))
+ (inputs
+ `(("fuse" ,fuse)))
+ (propagated-inputs
+ `(("python-paramiko" ,python-paramiko)))
+ (home-page "https://github.com/rianhunter/fusepyng")
+ (synopsis "Simple ctypes bindings for FUSE")
+ (description "@code{fusepyng} is a Python module that provides a simple
+interface to FUSE on various operating systems. It's just one file and is
+implemented using @code{ctypes}.")
+ (license license:isc)))
+
(define-public python2-gdrivefs
(package
(name "python2-gdrivefs")