summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Darrington <jmd@gnu.org>2016-09-18 10:15:39 +0200
committerJohn Darrington <jmd@gnu.org>2016-09-18 14:42:26 +0200
commite4360e16f932d0554ac9b1fe01b5c383bb0392ce (patch)
tree762c1fc3a67aebbb7a76e96ec815b39804007126 /gnu
parent5d87088c3921b7f240eb71223e2e078d39ba1bf5 (diff)
downloadpatches-e4360e16f932d0554ac9b1fe01b5c383bb0392ce.tar
patches-e4360e16f932d0554ac9b1fe01b5c383bb0392ce.tar.gz
gnu: gtk+ use modify-phases
* gnu/packages/gtk.scm (arguments): Replace alist-cons-before with modify-phases
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/gtk.scm26
1 files changed, 12 insertions, 14 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 5f55c1ee6f..df79239951 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -673,20 +673,18 @@ application suites.")
#:configure-flags (list (string-append "--with-html-dir="
(assoc-ref %outputs "doc")
"/share/gtk-doc/html"))
- #:phases
- (alist-cons-before
- 'configure 'pre-configure
- (lambda _
- ;; Disable most tests, failing in the chroot with the message:
- ;; D-Bus library appears to be incorrectly set up; failed to read
- ;; machine uuid: Failed to open "/etc/machine-id": No such file or
- ;; directory.
- ;; See the manual page for dbus-uuidgen to correct this issue.
- (substitute* "testsuite/Makefile.in"
- (("SUBDIRS = gdk gtk a11y css reftests")
- "SUBDIRS = gdk"))
- #t)
- %standard-phases)))
+ #:phases (modify-phases %standard-phases
+ (add-before 'configure 'pre-configure
+ (lambda _
+ ;; Disable most tests, failing in the chroot with the message:
+ ;; D-Bus library appears to be incorrectly set up; failed to read
+ ;; machine uuid: Failed to open "/etc/machine-id": No such file or
+ ;; directory.
+ ;; See the manual page for dbus-uuidgen to correct this issue.
+ (substitute* "testsuite/Makefile.in"
+ (("SUBDIRS = gdk gtk a11y css reftests")
+ "SUBDIRS = gdk"))
+ #t)))))
(native-search-paths
(list (search-path-specification
(variable "GUIX_GTK3_PATH")