summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-02-24 03:05:13 -0500
committerLeo Famulari <leo@famulari.name>2017-02-24 13:22:07 -0500
commitc71011f80f17a7160d067a6b83e444b75f8bc527 (patch)
tree28857b796ab9393ce4515cef19360ac1f98b7993 /gnu
parent816417f5a48cbdf8e551b47d36bb56be17dd4b9e (diff)
downloadpatches-c71011f80f17a7160d067a6b83e444b75f8bc527.tar
patches-c71011f80f17a7160d067a6b83e444b75f8bc527.tar.gz
gnu: tcsh: Use modify-phases.
* gnu/packages/shells.scm (tcsh)[arguments]: Use modify-phases.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/shells.scm50
1 files changed, 25 insertions, 25 deletions
diff --git a/gnu/packages/shells.scm b/gnu/packages/shells.scm
index d9e0f93a1a..eb3e69bb86 100644
--- a/gnu/packages/shells.scm
+++ b/gnu/packages/shells.scm
@@ -240,32 +240,32 @@ written by Paul Haahr and Byron Rakitzis.")
`(("ncurses" ,ncurses)))
(arguments
`(#:phases
- (alist-cons-before
- 'check 'patch-test-scripts
- (lambda _
- ;; Take care of pwd
- (substitute* '("tests/commands.at" "tests/variables.at")
- (("/bin/pwd") (which "pwd")))
- ;; The .at files create shell scripts without shebangs. Erk.
- (substitute* "tests/commands.at"
- (("./output.sh") "/bin/sh output.sh"))
- (substitute* "tests/syntax.at"
- (("; other_script.csh") "; /bin/sh other_script.csh"))
- ;; Now, let's generate the test suite and patch it
- (system* "make" "tests/testsuite")
+ (modify-phases %standard-phases
+ (add-before 'check 'patch-test-scripts
+ (lambda _
+ ;; Take care of pwd
+ (substitute* '("tests/commands.at" "tests/variables.at")
+ (("/bin/pwd") (which "pwd")))
+ ;; The .at files create shell scripts without shebangs. Erk.
+ (substitute* "tests/commands.at"
+ (("./output.sh") "/bin/sh output.sh"))
+ (substitute* "tests/syntax.at"
+ (("; other_script.csh") "; /bin/sh other_script.csh"))
+ ;; Now, let's generate the test suite and patch it
+ (system* "make" "tests/testsuite")
- ;; This file is ISO-8859-1 encoded.
- (with-fluids ((%default-port-encoding #f))
- (substitute* "tests/testsuite"
- (("/bin/sh") (which "sh")))))
- (alist-cons-after
- 'install 'post-install
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let* ((out (assoc-ref %outputs "out"))
- (bin (string-append out "/bin")))
- (with-directory-excursion bin
- (symlink "tcsh" "csh"))))
- %standard-phases))))
+ ;; This file is ISO-8859-1 encoded.
+ (with-fluids ((%default-port-encoding #f))
+ (substitute* "tests/testsuite"
+ (("/bin/sh") (which "sh"))))
+ #t))
+ (add-after 'install 'post-install
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let* ((out (assoc-ref %outputs "out"))
+ (bin (string-append out "/bin")))
+ (with-directory-excursion bin
+ (symlink "tcsh" "csh"))
+ #t))))))
(home-page "http://www.tcsh.org/")
(synopsis "Unix shell based on csh")
(description