summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-03-16 12:26:07 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-03-16 12:27:40 +0100
commit2a69f48e0f86ec99575325e3b28b68c8ea220649 (patch)
treec57b4b792a99ee7473d425df0111d7c5906e6154 /gnu
parentd41ba524ed4aab46a418fb2c1a0163b0d82bb87b (diff)
downloadpatches-2a69f48e0f86ec99575325e3b28b68c8ea220649.tar
patches-2a69f48e0f86ec99575325e3b28b68c8ea220649.tar.gz
gnu: classpath-devel: Fix bootstrap phase.
* gnu/packages/java.scm (classpath-devel)[arguments]: Replace "bootstrap" build phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm4
1 files changed, 4 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index b4f64e2c2e..30acbaf0a5 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -694,6 +694,10 @@ the standard javac executable. The tool runs on JamVM instead of SableVM.")))
"--disable-gjdoc")
#:phases
(modify-phases %standard-phases
+ ;; XXX The bootstrap phase executes autogen.sh, which fails after
+ ;; complaining about the lack of gettext.
+ (replace 'bootstrap
+ (lambda _ (invoke "autoreconf" "-vif")))
(add-after 'unpack 'remove-unsupported-annotations
(lambda _
(substitute* (find-files "java" "\\.java$")