summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-02-27 08:29:05 +0200
committerEfraim Flashner <efraim@flashner.co.il>2017-02-27 08:29:05 +0200
commit1c598515cd1e969ca950107a6e01941f48e25c37 (patch)
tree110fad9e838602658c00206e6097317b55020cec /gnu
parent212c775c9cf6263770ea686eaed9bcf867a68bcd (diff)
downloadpatches-1c598515cd1e969ca950107a6e01941f48e25c37.tar
patches-1c598515cd1e969ca950107a6e01941f48e25c37.tar.gz
gnu: fontconfig: Fix test-suite for freetype update.
* gnu/packages/fontutils.scm (fontconfig)[arguments]: Add phase to fix the test-suite to have the input expected.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/fontutils.scm7
1 files changed, 6 insertions, 1 deletions
diff --git a/gnu/packages/fontutils.scm b/gnu/packages/fontutils.scm
index ea324d3cd2..136b5bc992 100644
--- a/gnu/packages/fontutils.scm
+++ b/gnu/packages/fontutils.scm
@@ -2,7 +2,7 @@
;;; Copyright © 2013, 2014, 2015 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2014, 2016 Eric Bavier <bavier@member.fsf.org>
;;; Copyright © 2016 Mark H Weaver <mhw@netris.org>
-;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -255,6 +255,11 @@ fonts to/from the WOFF2 format.")
"PYTHON=false")
#:phases
(modify-phases %standard-phases
+ (add-after 'unpack 'fix-tests-for-freetype-2.7.1
+ (lambda _
+ (substitute* "test/run-test.sh"
+ (("\\\| sort") "| cut -d' ' -f2 | sort"))
+ #t))
(replace 'install
(lambda _
;; Don't try to create /var/cache/fontconfig.