summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 19:03:15 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:39:01 +0200
commitdfd91541805d5d63ad70c701168758eea5a32e1c (patch)
treea792146e3af6f650823014700fb2841f82e810cb /gnu
parenta13acfbe5fd046b361190bcca52120f42108af9e (diff)
downloadpatches-dfd91541805d5d63ad70c701168758eea5a32e1c.tar
patches-dfd91541805d5d63ad70c701168758eea5a32e1c.tar.gz
gnu: Add java-osgi-framework.
* gnu/packages/java.scm (java-osgi-framework): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 207352b8b5..9237cca55c 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -5082,3 +5082,30 @@ the support annotations for metatype.")
and service platform for the Java programming language. This package contains
a repository service that contains resources.")
(license license:asl2.0)))
+
+(define-public java-osgi-framework
+ (package
+ (name "java-osgi-framework")
+ (version "1.8.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://central.maven.org/maven2/org/osgi/"
+ "org.osgi.framework/" version "/org.osgi.framework-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "1lwp2zfad3rybcc6q9bwz8xsgkc92ypzy5p6x54387f1qj65m73s"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "osgi-framework.jar"
+ #:tests? #f)); no tests
+ (inputs
+ `(("annotation" ,java-osgi-annotation)
+ ("resource" ,java-osgi-resource)
+ ("dto" ,java-osgi-dto)))
+ (home-page "http://www.osgi.org")
+ (synopsis "OSGi framework")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language.")
+ (license license:asl2.0)))