summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2016-02-28 20:42:13 +0100
committerRicardo Wurmus <rekado@elephly.net>2016-02-29 07:10:40 +0100
commitdaeb61f7a92a178b0ac4a5c11b62b962293517e5 (patch)
tree857ef4bbca61e022e369bdd7448a008d678e98e9 /gnu
parent823e2ed4b39547608438f91d1a594772890a7f27 (diff)
downloadpatches-daeb61f7a92a178b0ac4a5c11b62b962293517e5.tar
patches-daeb61f7a92a178b0ac4a5c11b62b962293517e5.tar.gz
gnu: guile-for-guile-emacs: Use guile-2.0 search paths.
* gnu/packages/guile.scm (guile-for-guile-emacs)[native-search-paths]: Use the same search paths as guile-2.0.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/guile.scm12
1 files changed, 11 insertions, 1 deletions
diff --git a/gnu/packages/guile.scm b/gnu/packages/guile.scm
index 5349fda081..882a62d09f 100644
--- a/gnu/packages/guile.scm
+++ b/gnu/packages/guile.scm
@@ -3,6 +3,7 @@
;;; Copyright © 2014, 2015 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Christopher Allan Webber <cwebber@dustycloud.org>
;;; Copyright © 2016 Alex Sassmannshausen <alex@pompo.co>
+;;; Copyright © 2016 Ricardo Wurmus <rekado@elephly.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -255,7 +256,16 @@ without requiring the source code to be rewritten.")
("flex" ,flex)
("texinfo" ,texinfo)
("gettext" ,gnu-gettext)
- ,@(package-native-inputs guile-next)))))
+ ,@(package-native-inputs guile-next)))
+ ;; Same as in guile-2.0
+ (native-search-paths
+ (list (search-path-specification
+ (variable "GUILE_LOAD_PATH")
+ (files '("share/guile/site/2.0")))
+ (search-path-specification
+ (variable "GUILE_LOAD_COMPILED_PATH")
+ (files '("lib/guile/2.0/ccache"
+ "share/guile/site/2.0")))))))
;;;