summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-19 10:49:30 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:56 +0200
commit8d701b2cffe8b35e5f306fe8378b6df0a52b450d (patch)
tree97389725b93f29392a508b64e007c65728feb723 /gnu
parent89bafcf7f70072f6b8b44313aa1cfe37f0d24964 (diff)
downloadpatches-8d701b2cffe8b35e5f306fe8378b6df0a52b450d.tar
patches-8d701b2cffe8b35e5f306fe8378b6df0a52b450d.tar.gz
gnu: Add rust-markup5ever-0.8.
* gnu/packages/crates-io.scm (rust-markup5ever-0.8): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index baf7083b74..c10149e390 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -4925,6 +4925,40 @@ implementation of LZMA and xz stream encoding/decoding.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-markup5ever-0.8
+ (package
+ (name "rust-markup5ever")
+ (version "0.8.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "markup5ever" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "08ayl9aqjnmf7ly1ipy6dk3wjvyfn4w51l40jzh1fh984ykldbzi"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-log" ,rust-log-0.4)
+ ("rust-phf" ,rust-phf-0.7)
+ ("rust-string-cache" ,rust-string-cache-0.7)
+ ("rust-tendril" ,rust-tendril-0.4))
+ #:cargo-development-inputs
+ (("rust-phf-codegen" ,rust-phf-codegen-0.7)
+ ("rust-serde" ,rust-serde-1.0)
+ ("rust-serde-derive" ,rust-serde-derive-1.0)
+ ("rust-serde-json" ,rust-serde-json-1.0)
+ ("rust-string-cache-codegen"
+ ,rust-string-cache-codegen-0.4))))
+ (home-page "https://github.com/servo/html5ever")
+ (synopsis "Common code for xml5ever and html5ever")
+ (description
+ "Common code for xml5ever and html5ever.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-matches-0.1
(package
(name "rust-matches")