summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2017-10-01 18:58:47 +0200
committerJulien Lepiller <julien@lepiller.eu>2017-10-03 21:38:54 +0200
commit27103135ddbdfc3b2b6819c2706658834e5e9987 (patch)
tree3eed17534d0f3f004dc27e201dd41c038fd8c1e4 /gnu
parent0f0c52187bf8ace8d45c58acab4091fefe6835de (diff)
downloadpatches-27103135ddbdfc3b2b6819c2706658834e5e9987.tar
patches-27103135ddbdfc3b2b6819c2706658834e5e9987.tar.gz
gnu: Add java-osgi-util-promise.
* gnu/packages/java.scm (java-osgi-util-promise): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/java.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c0bbce31f7..17c05f3f23 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -4997,3 +4997,32 @@ the names for the attributes and directives for a service namespace.")
and service platform for the Java programming language. This package contains
an interface for a function that accepts a single argument and produces a result.")
(license license:asl2.0)))
+
+(define-public java-osgi-util-promise
+ (package
+ (name "java-osgi-util-promise")
+ (version "1.0.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://central.maven.org/maven2/org/osgi/"
+ "org.osgi.util.promise/"
+ version "/org.osgi.util.promise-"
+ version "-sources.jar"))
+ (sha256
+ (base32
+ "0y34dwiflg1c4ahvkswpf9z02xph2sr9fm04ia5493x3lshpw22c"))))
+ (build-system ant-build-system)
+ (arguments
+ `(#:jar-name "osgi-util-promise.jar"
+ #:tests? #f)); no tests
+ (inputs
+ `(("annotation" ,java-osgi-annotation)
+ ("function" ,java-osgi-util-function)))
+ (home-page "http://www.osgi.org")
+ (synopsis "Promise of a value")
+ (description
+ "OSGi, for Open Services Gateway initiative framework, is a module system
+and service platform for the Java programming language. This package contains
+an interface and utilitary classes for promises. A Promise represents a future
+value. It handles the interactions for asynchronous processing.")
+ (license license:asl2.0)))