summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2017-10-03 22:28:51 +0200
committerCyril Roelandt <tipecaml@gmail.com>2017-10-03 22:41:25 +0200
commit2299f5cd78a9874ec7797d02d9bd53cc3c30b698 (patch)
tree36c784d9a4a6869b308720ff9b3adede18d678e4 /gnu
parentf282aa530b91c8fecb910bc0a3323fcbd4d39ffb (diff)
downloadpatches-2299f5cd78a9874ec7797d02d9bd53cc3c30b698.tar
patches-2299f5cd78a9874ec7797d02d9bd53cc3c30b698.tar.gz
gnu: python-nose-timer: Add missing patch.
* gnu/packages/patches/python-nose-timer-drop-ordereddict.patch: New file. * gnu/local.mk: Add it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/python-nose-timer-drop-ordereddict.patch44
2 files changed, 45 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 88d24fab27..c802b7b340 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -984,6 +984,7 @@ dist_patch_DATA = \
%D%/packages/patches/python-genshi-isstring-helper.patch \
%D%/packages/patches/python-genshi-stripping-of-unsafe-script-tags.patch \
%D%/packages/patches/python2-larch-coverage-4.0a6-compatibility.patch \
+ %D%/packages/patches/python-nose-timer-drop-ordereddict.patch \
%D%/packages/patches/python-parse-too-many-fields.patch \
%D%/packages/patches/python2-rdflib-drop-sparqlwrapper.patch \
%D%/packages/patches/python-statsmodels-fix-tests.patch \
diff --git a/gnu/packages/patches/python-nose-timer-drop-ordereddict.patch b/gnu/packages/patches/python-nose-timer-drop-ordereddict.patch
new file mode 100644
index 0000000000..e1e71a332a
--- /dev/null
+++ b/gnu/packages/patches/python-nose-timer-drop-ordereddict.patch
@@ -0,0 +1,44 @@
+From 700076019b5aff72aac7651cc830aaef21ee9a47 Mon Sep 17 00:00:00 2001
+From: jakirkham <jakirkham@gmail.com>
+Date: Fri, 7 Jul 2017 05:57:56 -0400
+Subject: [PATCH] Drop ordereddict requirement (#84)
+
+* Drop ordereddict requirement
+
+As Python 2.7 is the minimum Python supported, every version of Python
+should have `ordereddict` preincluded in the standard library one way or
+another. So we can drop this dependency and just handle the differences
+between Python 2 and Python 3.
+---
+ nosetimer/plugin.py | 5 +----
+ setup.py | 1 -
+ 2 files changed, 1 insertion(+), 5 deletions(-)
+
+diff --git a/nosetimer/plugin.py b/nosetimer/plugin.py
+index ef28e11..d093a51 100644
+--- a/nosetimer/plugin.py
++++ b/nosetimer/plugin.py
+@@ -12,10 +12,7 @@
+ except ImportError:
+ import queue as Queue
+
+-try:
+- from collections import OrderedDict
+-except ImportError:
+- from ordereddict import OrderedDict
++from collections import OrderedDict
+
+
+ # define constants
+diff --git a/setup.py b/setup.py
+index 6a55b82..d249325 100755
+--- a/setup.py
++++ b/setup.py
+@@ -27,7 +27,6 @@
+ install_requires=[
+ 'nose',
+ 'termcolor',
+- 'ordereddict',
+ ],
+ license='MIT',
+ entry_points={