summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-19 09:55:19 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:52 +0200
commite9f0f7bca366f378cb917e6ab1454ea552b444f5 (patch)
treefff3e524fe7927b16f121caaf8c847462773f152 /gnu
parentff9ca851229b5eed585ccb53c6c7a9c67c178419 (diff)
downloadpatches-e9f0f7bca366f378cb917e6ab1454ea552b444f5.tar
patches-e9f0f7bca366f378cb917e6ab1454ea552b444f5.tar.gz
gnu: Add rust-parking-lot-0.9.
* gnu/packages/crates-io.scm (rust-parking-lot-0.9): New variable. (rust-parking-lot-0.8): Inherit from rust-parking-lot-0.9. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm35
1 files changed, 30 insertions, 5 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index e1a1f1c11d..18b6f8139f 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -5634,10 +5634,10 @@ normally prevent moving a type that has been borrowed from.")
(description "Portable Packed SIMD vectors.")
(license (list license:asl2.0 license:expat))))
-(define-public rust-parking-lot-0.8
+(define-public rust-parking-lot-0.9
(package
(name "rust-parking-lot")
- (version "0.8.0")
+ (version "0.9.0")
(source
(origin
(method url-fetch)
@@ -5646,13 +5646,13 @@ normally prevent moving a type that has been borrowed from.")
(string-append name "-" version ".tar.gz"))
(sha256
(base32
- "1rrcdalr8l5zx3bw28l376321l6dnd6rqnsqsl0ygk01fy0nfxzs"))))
+ "0lk2vq3hp88ygpgsrypdr3ss71fidnqbykva0csgxhmn5scb2hpq"))))
(build-system cargo-build-system)
(arguments
`(#:skip-build? #t
#:cargo-inputs
- (("rust-lock-api" ,rust-lock-api-0.2)
- ("rust-parking-lot-core" ,rust-parking-lot-core-0.5))
+ (("rust-lock-api" ,rust-lock-api-0.3)
+ ("rust-parking-lot-core" ,rust-parking-lot-core-0.6))
#:cargo-development-inputs
(("rust-bincode" ,rust-bincode-1.1)
("rust-lazy-static" ,rust-lazy-static-1.3)
@@ -5665,6 +5665,31 @@ normally prevent moving a type that has been borrowed from.")
synchronization primitives.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-parking-lot-0.8
+ (package
+ (inherit rust-parking-lot-0.9)
+ (name "rust-parking-lot")
+ (version "0.8.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "parking_lot" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1rrcdalr8l5zx3bw28l376321l6dnd6rqnsqsl0ygk01fy0nfxzs"))))
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-lock-api" ,rust-lock-api-0.2)
+ ("rust-parking-lot-core" ,rust-parking-lot-core-0.5))
+ #:cargo-development-inputs
+ (("rust-bincode" ,rust-bincode-1.1)
+ ("rust-lazy-static" ,rust-lazy-static-1.3)
+ ("rust-rand" ,rust-rand-0.4)
+ ("rust-rustc-version" ,rust-rustc-version-0.2))))))
+
(define-public rust-parking-lot-core-0.5
(package
(name "rust-parking-lot-core")