summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2018-02-12 21:52:43 +0100
committerRicardo Wurmus <rekado@elephly.net>2018-02-13 13:37:34 +0100
commit7d4de988a7b376358ff074803187546874f87376 (patch)
tree4edd7fc0b5caef7a09d091298fd753b06a899239 /gnu
parentc74dacd531778d55d15a2230795773213c925a72 (diff)
downloadpatches-7d4de988a7b376358ff074803187546874f87376.tar
patches-7d4de988a7b376358ff074803187546874f87376.tar.gz
gnu: ghc-extra: Update to 1.6.3.
* gnu/packages/haskell.scm (ghc-extra): Update to 1.6.3. [inputs]: Add ghc-clock.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/haskell.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/haskell.scm b/gnu/packages/haskell.scm
index d8144c3214..cd944f4154 100644
--- a/gnu/packages/haskell.scm
+++ b/gnu/packages/haskell.scm
@@ -2607,7 +2607,7 @@ Strings.")
(define-public ghc-extra
(package
(name "ghc-extra")
- (version "1.4.2")
+ (version "1.6.3")
(source
(origin
(method url-fetch)
@@ -2617,9 +2617,11 @@ Strings.")
".tar.gz"))
(sha256
(base32
- "1h9hxkrqrqscx420yz1lmivbrhi6jc3a5ap61vkxd2mhdgark9hf"))))
+ "06ds0jlx6sljwdf63l154qbzia9mnsri79i9qm3xikky3nj9ia1m"))))
(build-system haskell-build-system)
- (inputs `(("ghc-quickcheck" ,ghc-quickcheck)))
+ (inputs
+ `(("ghc-clock" ,ghc-clock)
+ ("ghc-quickcheck" ,ghc-quickcheck)))
(home-page "https://github.com/ndmitchell/extra")
(synopsis "Extra Haskell functions")
(description "This library provides extra functions for the standard