summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorTanguy Le Carrour <tanguy@bioneland.org>2019-10-28 15:41:33 +0100
committerMathieu Othacehe <m.othacehe@gmail.com>2019-10-29 08:38:28 +0100
commitb2ac2508b09f264b11721fa42edefd2b96ac6476 (patch)
tree6cc7312d8c2f946c76105dfa47b179c19c415b8c /gnu
parentaee92957b5032196cb830f0288557de864c9c644 (diff)
downloadpatches-b2ac2508b09f264b11721fa42edefd2b96ac6476.tar
patches-b2ac2508b09f264b11721fa42edefd2b96ac6476.tar.gz
gnu: Add python-clikit.
* gnu/packages/python-xyz.scm (python-clikit): New public variable. Signed-off-by: Mathieu Othacehe <m.othacehe@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index e082351e36..00bc41083a 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -10686,6 +10686,28 @@ daemon. It is the client side software which allows storing values in one or
more, possibly remote, memcached servers.")
(license license:psfl)))
+(define-public python-clikit
+ (package
+ (name "python-clikit")
+ (version "0.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "clikit" version))
+ (sha256
+ (base32
+ "0dc8czib5f4j9px1ivcpqnmivnx2zjpc0xb00ldrhsqylks7r06n"))))
+ (build-system python-build-system)
+ (propagated-inputs
+ `(("python-pastel" ,python-pastel)
+ ("python-pylev" ,python-pylev)))
+ (home-page "https://github.com/sdispater/clikit")
+ (synopsis "Group of utilities to build command line interfaces")
+ (description
+ "CliKit is a group of utilities to build testable command line
+interfaces.")
+ (license license:expat)))
+
(define-public python-lazy-object-proxy
(package
(name "python-lazy-object-proxy")