summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-01-26 22:04:08 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-01-26 22:04:08 +0100
commitd59a8ac6296054fe22b87ae7ade14ea105f3f312 (patch)
tree2632ed4787bbd299db431938754f389f39373cf1 /gnu
parentf08d34a007e8b35f2ea6b27ac057d63bfcb84634 (diff)
downloadpatches-d59a8ac6296054fe22b87ae7ade14ea105f3f312.tar
patches-d59a8ac6296054fe22b87ae7ade14ea105f3f312.tar.gz
gnu: crawl: Use INVOKE.
* gnu/packages/games.scm (crawl)[arguments]: Use INVOKE in "check" phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/games.scm8
1 files changed, 4 insertions, 4 deletions
diff --git a/gnu/packages/games.scm b/gnu/packages/games.scm
index 34f7c4c192..8d388c0fdc 100644
--- a/gnu/packages/games.scm
+++ b/gnu/packages/games.scm
@@ -4489,10 +4489,10 @@ fish. The whole game is accompanied by quiet, comforting music.")
(setenv "HOME" (getcwd))
;; Fake a terminal for the test cases.
(setenv "TERM" "xterm-256color")
- (zero? (apply system* "make" "debug" "test"
- (format #f "-j~d" (parallel-job-count))
- ;; Force command line build for test cases.
- (append make-flags '("GAME=crawl" "TILES=")))))))))
+ (apply invoke "make" "debug" "test"
+ (format #f "-j~d" (parallel-job-count))
+ ;; Force command line build for test cases.
+ (append make-flags '("GAME=crawl" "TILES="))))))))
(synopsis "Roguelike dungeon crawler game")
(description "Dungeon Crawl Stone Soup is a roguelike adventure through
dungeons filled with dangerous monsters in a quest to find the mystifyingly