summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorJohn Soo <jsoo1@asu.edu>2019-12-19 10:40:02 -0800
committerEfraim Flashner <efraim@flashner.co.il>2020-01-02 20:16:56 +0200
commit9edb05476bd424cd23da11fa91e04b4cc58bf098 (patch)
treecc8582e487620018779de02eb39dd733fd7421e7 /gnu
parenta51fe3f0bebe08178034e85eba9eb4460f22156c (diff)
downloadpatches-9edb05476bd424cd23da11fa91e04b4cc58bf098.tar
patches-9edb05476bd424cd23da11fa91e04b4cc58bf098.tar.gz
gnu: Add rust-string-cache-codegen-0.4.
* gnu/packages/crates-io.scm (rust-string-cache-codegen-0.4): New variable. Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/crates-io.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index ebdab44cdc..1fd4906899 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -9010,6 +9010,36 @@ crate.")
developed as part of the Servo project.")
(license (list license:asl2.0 license:expat))))
+(define-public rust-string-cache-codegen-0.4
+ (package
+ (name "rust-string-cache-codegen")
+ (version "0.4.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "string-cache-codegen" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "1npl9zq9cd16d7irksblgk7l7g6qknnzsmr12hrhky2fcpp1xshy"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:skip-build? #t
+ #:cargo-inputs
+ (("rust-phf-generator" ,rust-phf-generator-0.7)
+ ("rust-phf-shared" ,rust-phf-shared-0.7)
+ ("rust-proc-macro2" ,rust-proc-macro2-0.4)
+ ("rust-quote" ,rust-quote-1.0)
+ ("rust-string-cache-shared"
+ ,rust-string-cache-shared-0.3))))
+ (home-page "https://github.com/servo/string-cache")
+ (synopsis "Codegen library for string-cache")
+ (description
+ "This package provides a codegen library for string-cache,
+developed as part of the Servo project.")
+ (license (list license:asl2.0 license:expat))))
+
(define-public rust-string-cache-shared-0.3
(package
(name "rust-string-cache-shared")