summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2019-03-25 16:02:15 +0100
committerRicardo Wurmus <rekado@elephly.net>2019-03-25 16:02:15 +0100
commit3080b81af63c201decc96f8ba62ae174cdc574a2 (patch)
treeff2e86e633175d7b3275a94352c14da5c98f74d1 /gnu
parenta0583c0d1392a3401116faed50c7ccf534d0c4c4 (diff)
downloadpatches-3080b81af63c201decc96f8ba62ae174cdc574a2.tar
patches-3080b81af63c201decc96f8ba62ae174cdc574a2.tar.gz
gnu: Add r-hapassoc.
* gnu/packages/cran.scm (r-hapassoc): New variable.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/cran.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index fe69ee8fc4..c10af5fa2e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -12802,3 +12802,25 @@ following the algorithm of Yang (Evolution, 1998, 52(4):950-956). Functions
are also given to test via randomisations the significance of each F and
variance components, using the likelihood-ratio statistics G.")
(license license:gpl2+)))
+
+(define-public r-hapassoc
+ (package
+ (name "r-hapassoc")
+ (version "1.2-8")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "hapassoc" version))
+ (sha256
+ (base32
+ "0qs5jl0snzfchgpp6pabncwywxcmi743g91jvjiyyzw0lw85yv4s"))))
+ (build-system r-build-system)
+ (home-page "http://stat.sfu.ca/statgen/research/hapassoc.html")
+ (synopsis "Inference of trait associations with SNP haplotypes")
+ (description
+ "Hapassoc performs likelihood inference of trait associations with
+haplotypes and other covariates in @dfn{generalized linear models} (GLMs). The
+functions are developed primarily for data collected in cohort or
+cross-sectional studies. They can accommodate uncertain haplotype phase and
+handle missing genotypes at some SNPs.")
+ (license license:gpl2)))