summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-11-22 21:50:54 -0600
committerLudovic Courtès <ludo@gnu.org>2019-12-02 10:19:30 +0100
commitc4c59b08fe9bc2f7dfe2730b4f30532f5868bce6 (patch)
tree0a6f6a1cd6b33d42898409a8556277d3879a1f58 /gnu
parent5005b6a1c98f840aaab78a04f883872bafad8d8e (diff)
downloadpatches-c4c59b08fe9bc2f7dfe2730b4f30532f5868bce6.tar
patches-c4c59b08fe9bc2f7dfe2730b4f30532f5868bce6.tar.gz
gnu: Add emacs-shrink-path.
* gnu/packages/emacs-xyz.scm (emacs-shrink-path): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 23c5986344..637bf0c9e3 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19953,3 +19953,28 @@ Google guidelines.")
(description "Helm Fish Completion is a Helm interface for Emacs
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+
+(define-public emacs-shrink-path
+ (package
+ (name "emacs-shrink-path")
+ (version "0.3.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://gitlab.com/bennya/shrink-path.el.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "0kx0c4syd7k6ff9j463bib32pz4wq0rzjlg6b0yqnymlzfr1mbki"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (propagated-inputs
+ `(("emacs-s" ,emacs-s)
+ ("emacs-dash" ,emacs-dash)
+ ("emacs-f" ,emacs-f)))
+ (home-page "https://gitlab.com/bennya/shrink-path.el")
+ (synopsis "Fish-style path truncation in emacs-lisp")
+ (description "This package provides utility functions that allow for
+Fish-style truncated directories in eshell and various modelines.")
+ (license license:gpl3+)))