summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorBrett Gilio <brettg@posteo.net>2019-11-22 21:51:56 -0600
committerLudovic Courtès <ludo@gnu.org>2019-12-02 10:19:30 +0100
commitbdc11c0f3ae0027ce9f3d2c9a01876fa33a8582e (patch)
tree80878c95c159ca7c351de84c2eacd54dec3d2ed2 /gnu
parentc4c59b08fe9bc2f7dfe2730b4f30532f5868bce6 (diff)
downloadpatches-bdc11c0f3ae0027ce9f3d2c9a01876fa33a8582e.tar
patches-bdc11c0f3ae0027ce9f3d2c9a01876fa33a8582e.tar.gz
gnu: Add emacs-doom-modeline.
* gnu/packages/emacs-xyz.scm (emacs-doom-modeline): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/emacs-xyz.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/emacs-xyz.scm b/gnu/packages/emacs-xyz.scm
index 637bf0c9e3..5f237677b0 100644
--- a/gnu/packages/emacs-xyz.scm
+++ b/gnu/packages/emacs-xyz.scm
@@ -19954,6 +19954,33 @@ Google guidelines.")
fish-completion. It can be used in both Eshell and M-x shell.")
(license license:gpl3+))))
+(define-public emacs-doom-modeline
+ (package
+ (name "emacs-doom-modeline")
+ (version "2.7.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/seagle0128/doom-modeline.git")
+ (commit (string-append "v" version))))
+ (sha256
+ (base32
+ "16qlakgbwwjfr013g0cly4js4v9cfhxb8fn7zmn124f788m22357"))
+ (file-name (git-file-name name version))))
+ (build-system emacs-build-system)
+ (arguments
+ `(#:test-command '("ert-runner")))
+ (native-inputs `(("emacs-ert-runner" ,emacs-ert-runner)))
+ (propagated-inputs
+ `(("emacs-all-the-icons" ,emacs-all-the-icons)
+ ("emacs-shrink-path" ,emacs-shrink-path)))
+ (synopsis "Fancy and fast mode-line inspired by minimalism design")
+ (description "Doom modeline is a complete modeline for GNU Emacs inspired
+by the Doom theme collection. This modeline features support for mode-specific
+icon support, git integration, and several other utilities.")
+ (home-page "https://github.com/seagle0128/doom-modeline/")
+ (license license:gpl3+)))
+
(define-public emacs-shrink-path
(package
(name "emacs-shrink-path")