summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2014-12-31 03:47:40 -0500
committerMark H Weaver <mhw@netris.org>2015-01-07 12:34:10 -0500
commit8eb8048432f57254e07d48ab17890cbeca50e96f (patch)
tree71460bde05b5b2aecddb8d858c71fb56d1ee80a8 /gnu
parent270b501ee2b1b4ea4003a60b5568fc4dcb09d9db (diff)
downloadpatches-8eb8048432f57254e07d48ab17890cbeca50e96f.tar
patches-8eb8048432f57254e07d48ab17890cbeca50e96f.tar.gz
Move 'nix-system->gnu-triplet' to (guix utils) and export it.
* gnu/packages/commencement.scm (nix-system->gnu-triplet): Move to... * guix/utils.scm (nix-system->gnu-triplet): ... here. Fix docstring typo.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/commencement.scm13
1 files changed, 0 insertions, 13 deletions
diff --git a/gnu/packages/commencement.scm b/gnu/packages/commencement.scm
index 20831de997..e6d03b184f 100644
--- a/gnu/packages/commencement.scm
+++ b/gnu/packages/commencement.scm
@@ -122,19 +122,6 @@
("file" ,file-boot0)
,@%bootstrap-inputs))
-(define* (nix-system->gnu-triplet
- #:optional (system (%current-system)) (vendor "unknown"))
- "Return an a guess of the GNU triplet corresponding to Nix system
-identifier SYSTEM."
- (let* ((dash (string-index system #\-))
- (arch (substring system 0 dash))
- (os (substring system (+ 1 dash))))
- (string-append arch
- "-" vendor "-"
- (if (string=? os "linux")
- "linux-gnu"
- os))))
-
(define* (boot-triplet #:optional (system (%current-system)))
;; Return the triplet used to create the cross toolchain needed in the
;; first bootstrapping stage.