summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2019-12-02 11:01:49 +0200
committerEfraim Flashner <efraim@flashner.co.il>2019-12-02 15:12:46 +0200
commit61b77ff307b875bf198dd3d71ef64d1871d0ac6e (patch)
treeb6a13c724f0404eeccd174cb6572bc0a74fa1223 /gnu
parentc2b2c8e9e7ce3e12b23a6d27162dc98450d4f4d9 (diff)
downloadpatches-61b77ff307b875bf198dd3d71ef64d1871d0ac6e.tar
patches-61b77ff307b875bf198dd3d71ef64d1871d0ac6e.tar.gz
gnu: python-pillow: Replace check phase.
* gnu/packages/python-xyz.scm (python-pillow)[arguments]: Since 'check always come after 'install, replace 'check phase rather than recreate it.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/python-xyz.scm3
1 files changed, 1 insertions, 2 deletions
diff --git a/gnu/packages/python-xyz.scm b/gnu/packages/python-xyz.scm
index aef970cd88..59f712844f 100644
--- a/gnu/packages/python-xyz.scm
+++ b/gnu/packages/python-xyz.scm
@@ -4705,8 +4705,7 @@ the OleFileIO module from PIL, the Python Image Library.")
(lambda _
(substitute* "setup.py"
(("\\['/sbin/ldconfig', '-p'\\]") "['true']"))))
- (delete 'check) ; We must run checks after python-pillow is installed.
- (add-after 'install 'check-installed
+ (replace 'check
(lambda* (#:key outputs inputs #:allow-other-keys)
(begin
(setenv "HOME" (getcwd))