summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-01-14 08:40:22 -0500
committerMark H Weaver <mhw@netris.org>2015-01-14 08:41:47 -0500
commit54e612818b3ec5b1687d6d52c75b967a72bd5051 (patch)
treed67c444f1517c9752bbe12e49ab5537a72a40514 /gnu
parenta0ba3fc52028d84d18bfb0af3cd4f5c7e1fe9d8c (diff)
downloadpatches-54e612818b3ec5b1687d6d52c75b967a72bd5051.tar
patches-54e612818b3ec5b1687d6d52c75b967a72bd5051.tar.gz
gnu: tre: Build a locale for the tests.
* gnu/packages/tre.scm (tre)[arguments]: Add 'install-locales' phase.
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/tre.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/tre.scm b/gnu/packages/tre.scm
index 33d2cff093..1a1aa02ec9 100644
--- a/gnu/packages/tre.scm
+++ b/gnu/packages/tre.scm
@@ -1,5 +1,6 @@
;;; GNU Guix --- Functional package management for GNU
-;;; Copyright 2014 John Darrington
+;;; Copyright © 2014 John Darrington
+;;; Copyright © 2015 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -37,6 +38,17 @@
(base32 "0n36cgqys59r2gmb7jzbqiwsy790v8nbxk82d2n2saz0rp145ild"))))
(build-system gnu-build-system)
+ (arguments
+ `(#:phases (alist-cons-before
+ 'check 'install-locales
+ (lambda _
+ ;; The tests require the availability of the
+ ;; 'en_US.ISO-8859-1' locale.
+ (setenv "LOCPATH" (getcwd))
+ (zero? (system* "localedef" "--no-archive"
+ "--prefix" (getcwd) "-i" "en_US"
+ "-f" "ISO-8859-1" "./en_US.ISO-8859-1")))
+ %standard-phases)))
(synopsis "Approximate regex matching library and agrep utility")
(description "Superset of the POSIX regex API, enabling approximate
matching. Also ships a version of the agrep utility which behaves similar to