summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-01-19 19:55:25 +0100
committerBen Woodcroft <donttrustben@gmail.com>2017-03-12 10:28:06 +1000
commitfe68c8a9906f05de5f9f37a4dac05d35644dbd8a (patch)
treec296483c12f5b4695ac2c7e2eff0bbb76c75ba4b /gnu
parent362ea0dc2992442321c39700264415975360611e (diff)
downloadpatches-fe68c8a9906f05de5f9f37a4dac05d35644dbd8a.tar
patches-fe68c8a9906f05de5f9f37a4dac05d35644dbd8a.tar.gz
gnu: Add r-mnormt.
* gnu/packages/statistics.scm (r-mnormt): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index eb52c3b8ed..79f7e56f1a 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4704,3 +4704,26 @@ classification and regression models.")
computations taking place in C++ code, and support for interrupting those computations
even in multithreaded code, typically using OpenMP.")
(license license:gpl3+)))
+
+(define-public r-mnormt
+ (package
+ (name "r-mnormt")
+ (version "1.5-5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "mnormt" version))
+ (sha256
+ (base32
+ "1b34xxrnf35khsx82mhvmk96sgfr2flyasaah7qkb2976pwxay7z"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "http://azzalini.stat.unipd.it/SW/Pkg-mnormt")
+ (synopsis "Multivariate normal and \"t\" distributions")
+ (description
+ "This package provides functions for computing the density and the
+distribution function of multivariate normal and \"t\" random variables, and
+for generating random vectors sampled from these distributions. Probabilities
+are computed via non-Monte Carlo methods.")
+ (license license:gpl2+)))