summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 11:47:02 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-11 11:47:02 +1000
commitd4cebae286fec90deae7c0cb829c8d57218c63fc (patch)
treeea99ceb59938c8b5b858b5601fb13208f20c9b39 /gnu
parentfbf45d6ea7c038b5c1a718b9b927fd64af8c5a54 (diff)
downloadpatches-d4cebae286fec90deae7c0cb829c8d57218c63fc.tar
patches-d4cebae286fec90deae7c0cb829c8d57218c63fc.tar.gz
gnu: Add r-vgam.
* gnu/packages/statistics.scm (r-vgam): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm25
1 files changed, 25 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index 5422603682..6045c796d2 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4376,3 +4376,28 @@ clustering by merging Gaussian mixture components, as well as symmetric and
asymmetric discriminant projections for visualisation of the separation of
groupings.")
(license license:gpl2+)))
+
+(define-public r-vgam
+ (package
+ (name "r-vgam")
+ (version "1.0-3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "VGAM" version))
+ (sha256
+ (base32
+ "0wr6szcpj8r4a1rlzgd6iym7khin69fmvxcf37iyvs8mms86dfr3"))))
+ (properties `((upstream-name . "VGAM")))
+ (build-system r-build-system)
+ (inputs
+ `(("gfortran" ,gfortran)))
+ (home-page "https://www.stat.auckland.ac.nz/~yee/VGAM")
+ (synopsis "Vector generalized linear and additive models")
+ (description
+ "This package is an implementation of about 6 major classes of statistical
+regression models. Currently only fixed-effects models are implemented, i.e.,
+no random-effects models. Many (150+) models and distributions are estimated
+by maximum likelihood estimation (MLE) or penalized MLE, using Fisher scoring.
+VGLMs can be loosely thought of as multivariate generalised linear models.")
+ (license license:gpl2+)))