summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 15:19:47 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-12 10:28:06 +1000
commitc549864d9002f885d420e95042137235f0accf98 (patch)
treeb012d17c655b690be81b130d11af1eb214137466 /gnu
parent49dc1fa5cb506ee2442d05488efea843a82aaaa5 (diff)
downloadpatches-c549864d9002f885d420e95042137235f0accf98.tar
patches-c549864d9002f885d420e95042137235f0accf98.tar.gz
gnu: Add r-nloptr.
* gnu/packages/statistics.scm (r-nloptr): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm26
1 files changed, 26 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index eefc7be8c6..eaec0385f0 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4558,3 +4558,29 @@ models for conditional quantiles of a univariate response and several methods
for handling censored survival data. Portfolio selection methods based on
expected shortfall risk are also included.")
(license license:gpl2+)))
+
+(define-public r-nloptr
+ (package
+ (name "r-nloptr")
+ (version "1.0.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "nloptr" version))
+ (sha256
+ (base32
+ "1cypz91z28vhvwq2rzqjrbdc6a2lvfr2g16vid2sax618q6ai089"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
+ (inputs
+ `(("nlopt" ,nlopt)))
+ (home-page "http://cran.r-project.org/web/packages/nloptr")
+ (synopsis "R interface to NLopt")
+ (description
+ "This package is interface to NLopt, a library for nonlinear
+optimization. NLopt is a library for nonlinear optimization, providing a
+common interface for a number of different free optimization routines
+available online as well as original implementations of various other
+algorithms.")
+ (license license:lgpl3)))