summaryrefslogtreecommitdiff
path: root/gnu
diff options
context:
space:
mode:
authorRaoul Jean Pierre Bonnal <ilpuccio.febo@gmail.com>2017-03-11 15:46:28 +1000
committerBen Woodcroft <donttrustben@gmail.com>2017-03-12 10:28:06 +1000
commit51fc7d8c31f6c72ec34a4e49050f055b2033a12b (patch)
treee175fb4542c32c3fca93f91457bd6f9874852cbd /gnu
parentc549864d9002f885d420e95042137235f0accf98 (diff)
downloadpatches-51fc7d8c31f6c72ec34a4e49050f055b2033a12b.tar
patches-51fc7d8c31f6c72ec34a4e49050f055b2033a12b.tar.gz
gnu: Add r-lme4.
* gnu/packages/statistics.scm (r-lme4): New variable. Signed-off-by: Ben Woodcroft <donttrustben@gmail.com>
Diffstat (limited to 'gnu')
-rw-r--r--gnu/packages/statistics.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/statistics.scm b/gnu/packages/statistics.scm
index eaec0385f0..d3ea4f74bd 100644
--- a/gnu/packages/statistics.scm
+++ b/gnu/packages/statistics.scm
@@ -4584,3 +4584,30 @@ common interface for a number of different free optimization routines
available online as well as original implementations of various other
algorithms.")
(license license:lgpl3)))
+
+(define-public r-lme4
+ (package
+ (name "r-lme4")
+ (version "1.1-12")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "lme4" version))
+ (sha256
+ (base32
+ "0j60l5kgx1wvw2wm3jwfqwi63hammaq8gfcxzwa4h552likvaxi9"))))
+ (build-system r-build-system)
+ (native-inputs
+ `(("r-rcpp" ,r-rcpp)
+ ("r-rcppeigen" ,r-rcppeigen)))
+ (propagated-inputs
+ `(("r-minqa" ,r-minqa)
+ ("r-nloptr" ,r-nloptr)))
+ (home-page "http://cran.r-project.org/web/packages/lme4")
+ (synopsis "Linear mixed-effects models using eigen and S4")
+ (description
+ "This package provides fit linear and generalized linear mixed-effects
+models. The models and their components are represented using S4 classes and
+methods. The core computational algorithms are implemented using the Eigen
+C++ library for numerical linear algebra and RcppEigen glue.")
+ (license license:gpl2+)))